IProperty

Intellectual Property is a full-featured real estate extension for the Joomla! CMS

IPReserve

IPReserve is a reservation extension for IProperty.

IReport

Need to keep track of your IProperty stats? Meet IReport - a reporting tool for IProperty!

Work Force

Work Force is a staff listing extension for the Joomla! CMS. Show off your employees with style!

Report Card

Report Card is a testimonials extension for the Joomla! CMS. What are people saying about your company or product?

UTransport

Ultra Transport is a full-featured vehicle listing extension for the Joomla! CMS

Project Log

Project Log is a project management extension for the Joomla! CMS. The best part is, it's totally free!

Forums

Have pre-sales questions or need support for an existing subscription? Look no further - we have active support forums and pride ourselves on friendly and timely response!

The Thinkery

Not finding what you're looking for? Don't hesitate to contact us!

Before Posting...

Before posting questions in the forums, please be sure to read the FAQs by clicking on the FAQs link in the sidebar product menu. You must be logged in and have a valid subscription to access the SUPPORT FORUMS.
×
Support Policy Notice

As outlined in our Rules section (though never closely followed by our staff!), effective immediately we will no longer be taking time to provide customizations of our products.

Figured Out 403 page, but Project Link Leads to Blank Page

More
4 years 2 months ago #43211 by tim92109
tim92109 created the topic: Figured Out 403 page, but Project Link Leads to Blank Page
I just installed set everything up and both menu items used (project categories & submit project) lead to dead ends. Clicking on the sample category I created takes you to a blank page and clicking on submit gives you a 403 (403 You are not authorised to view this resource.).

Actually, I just went in and there were very few permissions allowed. I allowed permissions for the group, 'project managers' on everything in sections: category, project, & component options. It now lets me submit a project, but when you click on the menu item for 'categories' it goes to a blank page.

Now I changed the menu item to 'category' instead of 'categories' and it shows the projects in the sample category I created. But it now goes to that notorious blank page when you click on either the project I created or the sample project that came with the component. And in this list, the only other link is an 'edit' link which does nothing except for refresh the current page.

The main reason for this extension is to be able to upload and download plans between the office and field. I don't know if it even has that functionality because I can't get past the basics.

You're welcome to the credentials if you want to troubleshoot it. I can also give you access to the Joomla login, Joomla folder via FTP, and database [if you really need that].

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago - 4 years 2 months ago #43212 by tim92109
tim92109 replied the topic: Figured Out 403 page, but Project Link Leads to Blank Page
FYI, the URL of the current test installation is at sandbox.tjohns.co I installed it on my test location to see if it worked before putting it on the development site. I just noticed that even thought the menu items is set to guest access, they still produce 403's (not authorized to view this page).
Last Edit: 4 years 2 months ago by tim92109.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #43213 by vinny
vinny replied the topic: Figured Out 403 page, but Project Link Leads to Blank Page
Hi - can you disable sef urls in your configuration, refresh the home page and see if the menu links still throw errors? Just let us know. Thanks!

Vinny - The Thinkery
Good reviews on the JED make us work harder :) | IProperty | Work Force | Report Card

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #43214 by vinny
vinny replied the topic: Figured Out 403 page, but Project Link Leads to Blank Page
Also, if you'd like to send a link and admin login I can take a look for obvious issues. We were hoping to get more feedback from the beta release to reduce issues like this! :woohoo: Please send a link and login to This email address is being protected from spambots. You need JavaScript enabled to view it. and I'll take a look. thanks.

Vinny - The Thinkery
Good reviews on the JED make us work harder :) | IProperty | Work Force | Report Card

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #43215 by tim92109
tim92109 replied the topic: Figured Out 403 page, but Project Link Leads to Blank Page
I turned off SEF URLs and the problem went away. But it still exists (403) if you are logged in as a super administrator as opposed to the user group I created. If I change the 'access' to guest in the category settings, I can access the page, but the projects don't show up. Changed 'access' back to 'project management'.

Another thing I just found is that you can't access projects that are checked out in the back end as a super administrator (and I don't believe I left any pages without hitting 'save' or 'cancel'. So I'm not sure why they are checked out. I can select them and click the 'check in' button and that works.

I originally created the new group, 'project manager', as a child of 'registered'. I changed this to a child of 'public' instead just now. Not sure if that will make a difference on any of this.

I'm also not seeing any way to publish a new project on the front end. I changed the option in the back end to not require approval in the settings to possibly alleviate this.

I've probably given you enough to look at for now. I'm going to email you the credentials and leave the office, but I think I'll be online later tonight (definitely tomorrow) if you need anything else or a reply from me.

Thanks for doing this and you're also welcome for the troubleshooting from me.

Tim

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #43216 by vinny
vinny replied the topic: Figured Out 403 page, but Project Link Leads to Blank Page
Hi Tim - I've tried to reproduce this behavior with a fresh install with Joomla 3.3.6. I installed PL, saved the PL configuration, added a category, assigned a project to the category and created a menu item to the all categories, a single category, and the project form. All work as expected.... :dry:

This issue was never reported by any beta testers so I'm hoping it's a simple misconfiguration. Did you SAVE your PL configuration after installing? I'm wondering if you didn't save the configuration and created menu items that are expecting to use the PL global config options, if that's why it's breaking??

I never saw an email come in with a link and admin login credentials, so it's hard to guess -- but if you're able to send me access, I can take a look. Thanks!

And yes, thanks for your patience while we work some of the new release bugs out! :woohoo:

Vinny - The Thinkery
Good reviews on the JED make us work harder :) | IProperty | Work Force | Report Card

Please Log in or Create an account to join the conversation.

Moderators: vinny
Time to create page: 0.228 seconds